#pulp-dev: Pulp Triage 2016-05-20

Meeting started by mhrivnak at 14:31:14 UTC (full logs).

Meeting summary

    1. mhrivnak has joined triage (mhrivnak, 14:31:14)
    2. ttereshc has joined triage (ttereshc, 14:31:33)
    3. pcreech has joined triage (pcreech, 14:31:42)
    4. ipanova has joined triage (ipanova, 14:31:43)
    5. jcline has joined triage (jcline, 14:32:00)

  1. Incremental publish could use the wrong primary.xml during fast-forward publish - http://pulp.plan.io/issues/1088 (mhrivnak, 14:32:10)
    1. asmacdo has joined triage (asmacdo, 14:32:23)
    2. preethi has joined triage (preethi, 14:33:06)
    3. IDEA: Proposed for #1088: Priority: Normal, Severity: Low (mhrivnak, 14:34:37)
    4. bowlofeggs has joined triage (bowlofeggs, 14:35:02)
    5. jortel has joined triage (jortel, 14:37:00)
    6. AGREED: Priority: Normal, Severity: Low (mhrivnak, 14:37:18)

  2. pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893 (mhrivnak, 14:37:20)
  3. RPM import traceback (non-utf-8 metadata slipping through) - http://pulp.plan.io/issues/1903 (mhrivnak, 14:40:53)
    1. IDEA: Proposed for #1903: Priority: Low, Severity: Low (smyers, 14:44:42)
    2. smyers has joined triage (smyers, 14:44:42)
    3. AGREED: Priority: Low, Severity: Low (mhrivnak, 14:47:14)

  4. Unable to install packages with `.` in the name on pip==8.1.2 - http://pulp.plan.io/issues/1916 (mhrivnak, 14:47:17)
    1. IDEA: Proposed for #1916: closed notabug (smyers, 14:48:29)
    2. AGREED: closed notabug (mhrivnak, 14:50:17)

  5. pulp depends on m2crypto, which will not be ported to Python 3 - http://pulp.plan.io/issues/1918 (mhrivnak, 14:50:19)
    1. IDEA: Proposed for #1918: Priority: High, Severity: Medium (smyers, 14:50:59)
    2. https://en.wikipedia.org/wiki/High/Low_%28Nada_Surf_album%29 (bowlofeggs, 14:53:13)
    3. IDEA: Proposed for #1918: High Priority still, but change to Refactor or Task tracker (smyers, 14:55:18)
    4. AGREED: High Priority still, but change to Refactor or Task tracker (mhrivnak, 14:56:50)

  6. pulp depends on python-ldap, which will not be ported to Python 3 - http://pulp.plan.io/issues/1919 (mhrivnak, 14:56:53)
    1. IDEA: Proposed for #1919: High Priority still, but change to Refactor or Task tracker (bowlofeggs, 14:57:24)
    2. IDEA: Consensus for #1918 was to use the refactor tracker (smyers, 14:57:27)
    3. AGREED: High Priority still, but change to Refactor or Task tracker (mhrivnak, 14:57:37)

  7. pulp-rpm depends on pyliblzma, which will not be ported to Python 3 - http://pulp.plan.io/issues/1921 (mhrivnak, 14:57:38)
    1. IDEA: Proposed for #1921: High Priority still, but change to Refactor or Task tracker (bowlofeggs, 14:57:44)
    2. IDEA: Consensus for #1919 was also to use the refactor tracker (smyers, 14:57:46)
    3. AGREED: High Priority still, but change to Refactor or Task tracker (mhrivnak, 14:57:56)

  8. unhandled exception when changing feed to equivalent repo - http://pulp.plan.io/issues/1922 (mhrivnak, 14:57:58)
    1. IDEA: Consensus for #1921 was also to use the refactor tracker (smyers, 14:58:11)
    2. IDEA: This issue hurts my brain. (smyers, 14:59:12)
    3. IDEA: Proposed for #1922: Priority: Normal, Severity: Medium (bowlofeggs, 15:00:56)
    4. IDEA: Proposed for #1922: Priority: Normal, Severity: High (bowlofeggs, 15:03:50)
    5. AGREED: Priority: Normal, Severity: High (mhrivnak, 15:04:04)

  9. POST /pulp/api/v2/content/actions/delete_orphans/ is broken - http://pulp.plan.io/issues/1923 (mhrivnak, 15:04:06)
    1. IDEA: Proposed for #1923: Priority: Normal, Severity: High (bowlofeggs, 15:07:48)
    2. https://github.com/pulp/pulp/pull/1579#issuecomment-71904003 (asmacdo, 15:08:51)
    3. IDEA: Proposed for #1923: urgent medium 2.8.4 (mhrivnak, 15:11:33)
    4. AGREED: urgent medium 2.8.4 (mhrivnak, 15:13:11)

  10. pulp-server and python-pulp-streamer rpms both provide the pulp_streamer.service systemd unit - http://pulp.plan.io/issues/1924 (mhrivnak, 15:13:14)
    1. IDEA: Proposed for #1924: Skip this issue for this triage session. (mhrivnak, 15:16:01)
    2. IDEA: Proposed for #1924: Priority: High, Severity: Low (mhrivnak, 15:18:26)
    3. https://en.wikipedia.org/wiki/High/Low_%28Nada_Surf_album%29!propose (bowlofeggs, 15:18:43)
    4. AGREED: Priority: High, Severity: Low (mhrivnak, 15:19:02)

  11. v1 sync errors - http://pulp.plan.io/issues/1925 (mhrivnak, 15:19:04)
    1. IDEA: Proposed for #1925: Priority: High, Severity: Medium, Target Platform Release: 2.8.4 (smyers, 15:22:22)
    2. AGREED: Priority: High, Severity: Medium, Target Platform Release: 2.8.4 (mhrivnak, 15:22:30)

  12. package without epoch in the erratum pkglist is not handled correctly during publish - http://pulp.plan.io/issues/1926 (mhrivnak, 15:22:31)
    1. IDEA: Proposed for #1926: CLOSED NOTABUG, open a bug on pulp-fixtures to fix the demo repo generator (smyers, 15:24:39)
    2. IDEA: If it *is* a problem with el5, we can reopen it (smyers, 15:25:11)
    3. IDEA: Proposed for #1926: This issue cannot be triaged without more info. (smyers, 15:28:44)
    4. AGREED: This issue cannot be triaged without more info. (mhrivnak, 15:29:08)

  13. Cannot reuse distributor for directory and web publish - http://pulp.plan.io/issues/1928 (mhrivnak, 15:29:10)
    1. IDEA: Proposed for #1928: Priority: High, Severity: Medium (ipanova, 15:31:37)
    2. AGREED: Priority: High, Severity: Medium (mhrivnak, 15:32:14)

  14. The 0023_importer_tls_storage.py migration assumes that Importers always have configs when they do not - http://pulp.plan.io/issues/1929 (mhrivnak, 15:32:16)


Meeting ended at 15:32:59 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mhrivnak (114)
  2. smyers (107)
  3. bowlofeggs (107)
  4. pulpbot (101)
  5. jcline (25)
  6. jortel (15)
  7. asmacdo (14)
  8. ipanova (13)
  9. pcreech (10)
  10. ttereshc (5)
  11. preethi (2)
  12. ichimonji10 (2)
  13. bmbouter (1)


Generated by MeetBot 0.1.4.